Skip to content
CABLES & ADAPTORS

CABLES & ADAPTORS

Filters

  • Shireen DC-1042 - Outdoor Shielded Dry Gel Tape CAT5e FTP Cable Per meter

    Original price $2.90
    Original price $2.90 - Original price $2.90
    Original price $2.90
    Current price $2.58
    $2.58 - $2.58
    Current price $2.58
    70 in stock

    Shireen DC-1042 - Outdoor Shielded Dry Gel Tape CAT5e FTP Cable Per meter

    Original price $2.90
    Original price $2.90 - Original price $2.90
    Original price $2.90
    Current price $2.58
    $2.58 - $2.58
    Current price $2.58
    Save $0.32 Save $0.00
  • Shireen Inc RFC240 Cable 50 Ohm Coax Cable Per Metre

    Original price $7.00
    Original price $7.00 - Original price $7.00
    Original price $7.00
    Current price $6.23
    $6.23 - $6.23
    Current price $6.23
    50 in stock

    Shireen Inc RFC240 Cable 50 Ohm Coax Cable Per Metre

    Original price $7.00
    Original price $7.00 - Original price $7.00
    Original price $7.00
    Current price $6.23
    $6.23 - $6.23
    Current price $6.23
    Save $0.77 Save $0.00
  • Shireen Inc RFC400 Cable 1000ft Spool 50 Ohm Coax Cable

    Original price $1,619.00
    Original price $1,619.00 - Original price $1,619.00
    Original price $1,619.00
    Current price $1,440.06
    $1,440.06 - $1,440.06
    Current price $1,440.06
    12 in stock

    Shireen Inc RFC400 Cable 1000ft Spool 50 Ohm Coax Cable

    Original price $1,619.00
    Original price $1,619.00 - Original price $1,619.00
    Original price $1,619.00
    Current price $1,440.06
    $1,440.06 - $1,440.06
    Current price $1,440.06
    Save $178.94 Save $0.00
  • Shireen RFC400 50 Ohm Coax Cable Per Metre

    Original price $9.00
    Original price $9.00 - Original price $9.00
    Original price $9.00
    Current price $8.01
    $8.01 - $8.01
    Current price $8.01
    50 in stock

    Shireen RFC400 50 Ohm Coax Cable Per Metre

    Original price $9.00
    Original price $9.00 - Original price $9.00
    Original price $9.00
    Current price $8.01
    $8.01 - $8.01
    Current price $8.01
    Save $0.99 Save $0.00
  • Shireen Inc RFC195 Cable 1000ft Spool 50 Ohm Coax Cable Drum (305m)

    Original price $936.00
    Original price $936.00 - Original price $936.00
    Original price $936.00
    Current price $832.55
    $832.55 - $832.55
    Current price $832.55
    31 in stock

    Shireen Inc RFC195 Cable 1000ft Spool 50 Ohm Coax Cable Drum (305m)

    Original price $936.00
    Original price $936.00 - Original price $936.00
    Original price $936.00
    Current price $832.55
    $832.55 - $832.55
    Current price $832.55
    Save $103.45 Save $0.00
  • Shireen DC-2021 - Outdoor CAT6 FTP - 1000ft Spool

    Original price $551.00
    Original price $551.00 - Original price $551.00
    Original price $551.00
    Current price $490.11
    $490.11 - $490.11
    Current price $490.11
    48 in stock

    Shireen DC-2021 - Outdoor CAT6 FTP - 1000ft Spool

    Original price $551.00
    Original price $551.00 - Original price $551.00
    Original price $551.00
    Current price $490.11
    $490.11 - $490.11
    Current price $490.11
    Save $60.89 Save $0.00
  • Shireen DC-1021 - Outdoor CAT5e FTP - Shielded - 1000ft Spool

    Original price $451.00
    Original price $451.00 - Original price $451.00
    Original price $451.00
    Current price $401.16
    $401.16 - $401.16
    Current price $401.16
    50 in stock

    Shireen DC-1021 - Outdoor CAT5e FTP - Shielded - 1000ft Spool

    Original price $451.00
    Original price $451.00 - Original price $451.00
    Original price $451.00
    Current price $401.16
    $401.16 - $401.16
    Current price $401.16
    Save $49.84 Save $0.00
  • Shireen CAT-C5e RJ45 Smart Feed Connector 50pk

    Original price $63.00
    Original price $63.00 - Original price $63.00
    Original price $63.00
    Current price $56.04
    $56.04 - $56.04
    Current price $56.04
    34 in stock

    Shireen CAT-C5e RJ45 Smart Feed Connector 50pk

    Original price $63.00
    Original price $63.00 - Original price $63.00
    Original price $63.00
    Current price $56.04
    $56.04 - $56.04
    Current price $56.04
    Save $6.96 Save $0.00
  • Shireen CAT-C5e RJ45 Smart Feed Connector 100pk

    Original price $129.00
    Original price $129.00 - Original price $129.00
    Original price $129.00
    Current price $114.75
    $114.75 - $114.75
    Current price $114.75
    22 in stock

    Shireen CAT-C5e RJ45 Smart Feed Connector 100pk

    Original price $129.00
    Original price $129.00 - Original price $129.00
    Original price $129.00
    Current price $114.75
    $114.75 - $114.75
    Current price $114.75
    Save $14.25 Save $0.00
  • Shireen DC-2021 - Outdoor CAT6 FTP per metre

    Original price $2.90
    Original price $2.90 - Original price $2.90
    Original price $2.90
    Current price $2.51
    $2.51 - $2.51
    Current price $2.51
    50 in stock

    Shireen DC-2021 - Outdoor CAT6 FTP per metre

    Original price $2.90
    Original price $2.90 - Original price $2.90
    Original price $2.90
    Current price $2.51
    $2.51 - $2.51
    Current price $2.51
    Save $0.39 Save $0.00
  • Shireen SmartFeed CAT6 Shielded RJ45 Connectors (Pack of 100) - CON-RJ45-C6-100

    Original price $215.00
    Original price $215.00 - Original price $215.00
    Original price $215.00
    Current price $191.24
    $191.24 - $191.24
    Current price $191.24
    50 in stock

    Shireen SmartFeed CAT6 Shielded RJ45 Connectors (Pack of 100) - CON-RJ45-C6-100

    Original price $215.00
    Original price $215.00 - Original price $215.00
    Original price $215.00
    Current price $191.24
    $191.24 - $191.24
    Current price $191.24
    Save $23.76 Save $0.00
  • Shireen DC-2022 - Outdoor CAT6 Double Shielded FTP - 1000ft Spool

    Original price $724.00
    Original price $724.00 - Original price $724.00
    Original price $724.00
    Current price $643.98
    $643.98 - $643.98
    Current price $643.98
    50 in stock

    Shireen DC-2022 - Outdoor CAT6 Double Shielded FTP - 1000ft Spool

    Original price $724.00
    Original price $724.00 - Original price $724.00
    Original price $724.00
    Current price $643.98
    $643.98 - $643.98
    Current price $643.98
    Save $80.02 Save $0.00
  • Shireen DC-2042 Outdoor CAT6 Shielded With Gel Tape 305m

    Original price $559.00
    Original price $559.00 - Original price $559.00
    Original price $559.00
    Current price $497.22
    $497.22 - $497.22
    Current price $497.22
    43 in stock

    Shireen DC-2042 Outdoor CAT6 Shielded With Gel Tape 305m

    Original price $559.00
    Original price $559.00 - Original price $559.00
    Original price $559.00
    Current price $497.22
    $497.22 - $497.22
    Current price $497.22
    Save $61.78 Save $0.00
  • Shireen DC-1023 Outdoor Shielded CAT5e FTP with Messenger Wire 305m

    Original price $374.00
    Original price $374.00 - Original price $374.00
    Original price $374.00
    Current price $268.42
    $268.42 - $268.42
    Current price $268.42
    41 in stock

    Shireen DC-1023 Outdoor Shielded CAT5e FTP with Messenger Wire 305m

    Original price $374.00
    Original price $374.00 - Original price $374.00
    Original price $374.00
    Current price $268.42
    $268.42 - $268.42
    Current price $268.42
    Save $105.58 Save $0.00
  • Shireen CA-195 50ohm Coax Cable Per Metre

    Original price $5.00
    Original price $5.00 - Original price $5.00
    Original price $5.00
    Current price $4.32
    $4.32 - $4.32
    Current price $4.32
    50 in stock

    Shireen CA-195 50ohm Coax Cable Per Metre

    Original price $5.00
    Original price $5.00 - Original price $5.00
    Original price $5.00
    Current price $4.32
    $4.32 - $4.32
    Current price $4.32
    Save $0.68 Save $0.00
  • Shireen SmartFeed CAT6 Shielded RJ45 Connectors (Pack of 50) - CON-RJ45-C6-50

    Original price $109.00
    Original price $109.00 - Original price $109.00
    Original price $109.00
    Current price $96.96
    $96.96 - $96.96
    Current price $96.96
    50 in stock

    Shireen SmartFeed CAT6 Shielded RJ45 Connectors (Pack of 50) - CON-RJ45-C6-50

    Original price $109.00
    Original price $109.00 - Original price $109.00
    Original price $109.00
    Current price $96.96
    $96.96 - $96.96
    Current price $96.96
    Save $12.04 Save $0.00
  • Shireen Cat6 RJ45 Connectors SmartFeed CAT6 Shielded RJ45 Connectors (Pack of 10)

    Original price $31.00
    Original price $31.00 - Original price $31.00
    Original price $31.00
    Current price $26.76
    $26.76 - $26.76
    Current price $26.76
    50 in stock

    Shireen Cat6 RJ45 Connectors SmartFeed CAT6 Shielded RJ45 Connectors (Pack of 10)

    Original price $31.00
    Original price $31.00 - Original price $31.00
    Original price $31.00
    Current price $26.76
    $26.76 - $26.76
    Current price $26.76
    Save $4.24 Save $0.00
  • Shireen SmartFeed CAT6 Shielded RJ45 Connectors (Pack of 10) - CON-RJ45-C6-10

    Original price $31.00
    Original price $31.00 - Original price $31.00
    Original price $31.00
    Current price $26.76
    $26.76 - $26.76
    Current price $26.76
    50 in stock

    Shireen SmartFeed CAT6 Shielded RJ45 Connectors (Pack of 10) - CON-RJ45-C6-10

    Original price $31.00
    Original price $31.00 - Original price $31.00
    Original price $31.00
    Current price $26.76
    $26.76 - $26.76
    Current price $26.76
    Save $4.24 Save $0.00

Compare products

{"one"=>"Select 2 or 3 items to compare", "other"=>"{{ count }} of 3 items selected"}

Select first item to compare

Select second item to compare

Select third item to compare

Compare